由于ie浏览器对某些js不兼容,导致用ie打开网页会出现js效果不好用,那么我们门就应该对游客做个提示,让客户用新版本的浏览器打开页面.小糊涂网站建设来告诉大家代码是什么

<!--判断浏览器-->
<script type="text/javascript">
    if (navigator.appName == "Microsoft Internet Explorer" && navigator.appVersion.split(";")[1].replace(/[ ]/g, "") == "MSIE6.0") {
        alert("若想看到本站最佳效果建议使用谷歌、opera、火狐、safari浏览器或升级IE至9以上版本");
    }
    else if (navigator.appName == "Microsoft Internet Explorer" && navigator.appVersion.split(";")[1].replace(/[ ]/g, "") == "MSIE7.0") {
        alert("若想看到本站最佳效果建议使用谷歌、opera、火狐、safari浏览器或升级IE至9以上版本");
    }
    else if (navigator.appName == "Microsoft Internet Explorer" && navigator.appVersion.split(";")[1].replace(/[ ]/g, "") == "MSIE8.0") {
        alert("若想看到本站最佳效果建议使用谷歌、opera、火狐、safari浏览器或升级IE至9以上版本");
    }
    else if (navigator.appName == "Microsoft Internet Explorer" && navigator.appVersion.split(";")[1].replace(/[ ]/g, "") == "MSIE9.0") {
        alert("若想看到本站最佳效果建议使用谷歌、opera、火狐、safari浏览器或升级IE至9以上版本");
    } 
</script>

上面js分别对ie及ie版本进行判断并给于游客提示,